Intermittent Faxing Issues
Incident Report for Lincoln Public Schools
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 11:47 CST
Investigating
We are currently investigating this issue.
Posted Feb 28, 2024 - 08:40 CST
This incident affected: Communication and Collaboration (Faxing).