SmartFind and other PowerSchool products

Incident Report for Lincoln Public Schools

Resolved

PowerSchool has resolved the issue and continue to monitor.
Posted Feb 17, 2026 - 13:24 CST

Investigating

Several PowerSchool products are experiencing functionality issues. PowerSchool has identified the issue and working on a resolution.
Posted Feb 17, 2026 - 09:11 CST
This incident affected: Administrative and Business (Perform & Professional Learning, Smartfind, SmartFind Express).