LPS Operations and Computing Services engineering staff continue to collaborate with resources from three service providers. This has resulted in the indentification of more than one source of dropped calls. Remediation efforts in the form of procedural and configuration practices associated with system updates have been implemented. LPS and vendor partners are monitoring to determine the impact of these changes and address any other issues.
What does this mean? It is still possible that not all sources of dropped calls have been addressed.
Posted Nov 14, 2025 - 12:54 CST
Update
We are continuing to monitor for any further issues.
Posted Nov 14, 2025 - 09:28 CST
Monitoring
The number of dropped calls reported has dropped significantly over the past two days. We are still working with our provider to ensure the issue is fully resolved.
Posted Nov 07, 2025 - 13:56 CST
Investigating
Currently there is an issue with phone calls being disconnected randomly during inbound and outbound calls. We are working to resolve the issue.
Posted Nov 05, 2025 - 08:27 CST
This incident affected: Communication and Collaboration (Phone Services).