Chromebook Connectivity

Incident Report for Lincoln Public Schools

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 09:46 CDT

Investigating

Computing Services is investigating reports of Chromebook connectivity issues.
Posted Aug 31, 2026 - 08:41 CDT
This incident affected: Instruction (Chromebooks).