MyVideoSpot

Incident Report for Lincoln Public Schools

Resolved

Staff & students are able to sign in to MyVideoSpot once again.
Posted Feb 23, 2026 - 11:35 CST

Investigating

LPS staff & students are not able to sign in to MyVideoSpot at this time. Computing Services is reaching out to support.
Posted Feb 23, 2026 - 10:14 CST
This incident affected: Instruction (MyVideoSpot).