SchoolMessenger
Incident Report for Lincoln Public Schools
Resolved
SchoolMessenger logins are working as expected again.
Posted Apr 05, 2024 - 14:02 CDT
Identified
PowerSchool has identified an issue signing in to SchoolMessenger that is affecting LPS
Posted Apr 05, 2024 - 12:17 CDT
This incident affected: Communication and Collaboration (SchoolMessenger Communicate).