Follett Destiny Outage

Incident Report for Lincoln Public Schools

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 07:38 CDT

Monitoring

"Destiny and Aspen services have been fully restored following our workaround to the Microsoft Azure outage. Some users may still experience intermittent issues with eBooks in Destiny Discover while Microsoft continues to resolve their Azure-related disruptions."
Posted Oct 29, 2025 - 13:18 CDT

Identified

https://status.follettsoftware.com/ - "We are currently experiencing performance issues due to Azure issues which impacts Destiny Hosted customers. We are aware of these issues and are working diligently to restore performance. We sincerely apologize for any inconvenience this has caused."
Posted Oct 29, 2025 - 11:34 CDT
This incident affected: Instruction (Destiny Library Management).