Issues with Verizon

Incident Report for Lincoln Public Schools

Resolved

The issue with inbound Verizon calls has been resolved.
Posted Apr 16, 2025 - 13:00 CDT

Investigating

Verizon customers are not currently able to call LPS phone systems. LPS is monitoring the situation and working with involved vendors.
Posted Apr 16, 2025 - 12:13 CDT
This incident affected: Communication and Collaboration (Phone Services).