Canva

Incident Report for Lincoln Public Schools

Resolved

CloudFlare has resolved their issues.
Posted Nov 18, 2025 - 13:51 CST

Investigating

Canva is unavailable due to issues with its hosting service. Additional information here: https://www.canvastatus.com/
Posted Nov 18, 2025 - 07:48 CST
This incident affected: Communication and Collaboration (Canva).