Follett Destiny Outage

Incident Report for Lincoln Public Schools

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 13:03 CDT

Identified

Follett, the owner's of Destiny.lps.org, are currently experiencing an outage: https://www.follettcommunity.com/s/idea/0872J000000MtiFQAS/detail
Posted Aug 18, 2025 - 10:59 CDT
This incident affected: Instruction (Destiny Library Management).