Smartsheet

Incident Report for Lincoln Public Schools

Resolved

Smartsheet has implemented a fix and LPS staff are once again able to use.
Posted Aug 27, 2026 - 10:31 CDT

Investigating

Smartsheet is not loading consistently for LPS staff users.
Posted Aug 27, 2026 - 08:25 CDT
This incident affected: Administrative and Business (Smartsheet).