Various Cloud-based apps

Incident Report for Lincoln Public Schools

Resolved

CloudFlare has resolved their issues.
Posted Nov 18, 2025 - 13:51 CST

Investigating

Various cloud-based apps are unavailable due to issues with Cloudflare (a major cloud hosting service) and will not be available until these issues are resolved. This is not an exhaustive list but some included apps are: Canva, Quizlet, Blooket, and Gimkit.
Posted Nov 18, 2025 - 08:47 CST
This incident affected: Communication and Collaboration (Cloud Apps).