Internet Connectivity
Incident Report for Lincoln Public Schools
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 22:00 CST
Investigating
Currently, there is slow connectivity for all devices on the LPS network. Our internet Service Provider has stated there is a fiber cut and is working to resolve.
Posted Nov 15, 2024 - 12:35 CST
This incident affected: Network (Network).