WeVideo

Incident Report for Lincoln Public Schools

Resolved

LPS staff and students can log in to WeVideo once again.
Posted Aug 18, 2025 - 08:27 CDT

Investigating

LPS staff & students are unable to log in to WeVideo at this time. Computing Services is reaching out to them for support.
Posted Aug 18, 2025 - 08:01 CDT
This incident affected: Instruction (WeVideo).