MyVideoSpot & YouTube Videos

Incident Report for Lincoln Public Schools

Update

MyVideoSpot confirmed the issue, but did not find a specific cause. The alert is being left in place in case the issue resurfaces.
Posted Mar 26, 2025 - 10:31 CDT

Investigating

LPS staff and students are experiencing intermittent issues with loading and replaying YouTube content via MyVideoSpot. Computing Services has entered a support ticket with the vendor.
Posted Mar 25, 2025 - 16:16 CDT
This incident affects: Instruction (MyVideoSpot).