IIQ - Help Desk ticket platform

Incident Report for Lincoln Public Schools

Resolved

IIQ is working as expected and all features are available once again.
Posted Oct 27, 2025 - 14:09 CDT

Investigating

The Help Desk ticket system is not allowing users to access all features at this time. LPS is reaching out for support.
Posted Oct 27, 2025 - 13:40 CDT
This incident affected: Administrative and Business (IIQ - Help Desk Ticketing).