IIQ - Help Desk ticket platform

Incident Report for Lincoln Public Schools

Resolved

IIQ is functioning as expected once again.
Posted Oct 30, 2025 - 13:47 CDT

Investigating

The Help Desk ticketing platform is not responding at this time. Our vendor, IIQ, has acknowledged this issue and is working to resolve.
Posted Oct 30, 2025 - 12:50 CDT
This incident affected: Administrative and Business (IIQ - Help Desk Ticketing).